The odd bit

Once is an accident, twice is a coincidence, three times is an enemy action.

The odd bit - Once is an accident, twice is a coincidence, three times is an enemy action.

Tracing two more Vista issues

After successfully defeating Windows Vista in the media playback department, I’m tracing two more issues. I only noticed these issues last week when trying Futuremark‘s latest incarnation of the PCMark benchmark: PCMark Vantage.

The first issue doesn’t really have a performance impact. When starting PCMark Vantage, it told me Windows Mail was running. Ehh? Unfortunately it was not a detection error because Windows Mail was really running. That’s pretty strange because (a) I haven’t even configured any email client on my laptop and (b) I would certainly not use Outlook Express or its new version as my email client. But there’s even more weirdness involved. By tracing the winmail.exe process, I found out it was launched by the same process that caused the media playback issues: “svchost.exe -DcomLaunch”. What the hell?

I’m still trying to find out why Windows Mail gets launched by the Dcom server. The bad part is that there’s much less information available than with the media playback issue. If anyone has any clue, please let me know through the comments.

The second issue surfaced when copying the PCMark installer from my main machine to my laptop. Transferring files across the network is SLOW! And it can’t be the network… Initiating the transfer from my PC results in a sustained network throughput of 90%. Initiating it from my laptop makes the throughput peak very briefly, followed by a stall in network activity. The net result is a 20 second difference doing exactly the same transfer. For a ~650MB file on a 100 megabit network, that’s a huge difference.

A search on the internet quickly revealed I’m not the only one. I’ve tried several suggested fixes, but none of them improved the performance. I had my hopes set on a tweak of the new TCP/IP stack in Vista, namely:
netsh interface tcp set global autotuninglevel=disabled
but that didn’t help either. Again, magical solutions or hints are much appreciated.

Aside from those issues, I’ve been much happier with Vista once I disabled the indexing service (it really does trash the HDD) and system restore. Both “features” put a high burden on the HDD and the system feels much more responsive with those two things turned off.

Category: Microsoft, Vista
  • Dale says:

    I actually like the latest replacement for Outlook Express, Live Mail Desktop; I actually use Outlook 2007 but still hook in a hotmail account into Live Mail to stay familiarized with it since I support people who use it. Just make sure you update the default mail program that ships with Vista as the latest version is even nicer. If you didn’t know this version adds an RSS feed reader function. Go out to http://get.live.com/wlmail/overview for the latest version.

    My svchost.exe (DcomLaunch) is still consuming way to much processor on one installation of Vista averaging in the 30% range with some near 50% spikes. The result though is a less than acceptable performance experience.

    As a Microsoft Partner, I plan on posting into my Private Microsoft newsgroups to see what if anything I can learn. I’ll bookmark this post should I find anything worthwhile to share.

    2 January 2008 at 07:54
  • Ralph says:

    Hi Dale,

    Did you have any reaction or solutions for the DcomLaunch. I am experiencing the same issue only
    my svchost consumes 90%

    Regards,

    Ralph

    12 February 2009 at 09:50
  • Gary Osborn says:

    Same problems!

    24 February 2009 at 04:49
  • Pingback/Trackback

    winmail.exe | hilpers

Your email address will not be published. Required fields are marked *

*