The odd bit

Once is an accident, twice is a coincidence, three times is an enemy action.

The odd bit - Once is an accident, twice is a coincidence, three times is an enemy action.

Administrative shares in Windows 7

Those who have experience with NT-based operating systems on a network will certainly be familiar with the concept of administrative shares. If that doesn’t ring a bell, you access them like \\computername\c$. With this intro and the title of this post, you might be alarmed or enter panick mode fearing they might be gone in Microsoft’s latest OS iteration. Well don’t go into cardiac arrest because they are still there… but of course not without the odd problem.

Windows 7 still creates the administrative shares on install, but you can’t use them out of the box. First of all, you need to have File and Printer Sharing enabled. And the way to do that has once again been changed:

  1. Open the control panel.
  2. Go to Network and Internet.
  3. Go to Network and Sharing Center.
  4. In the left column, click on Change advanced sharing settings.
  5. There are two profiles. You probably don’t want this on when you’re on a public network so open Home or Work.
  6. Under the header File and Printer sharing, select the Turn on… option.

And now your administrative shares still don’t work 😛 You’ve just completed step 1 which implies there’s at least a step 2 and here it is: you also need to change the registry.

  1. Click on the orb (= the round button with the Windows logo in the taskbar) and type regedit in the search box.
  2. Open the registry editor.
  3. Navigate all the way to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.
  4. Right-click in the pane on the right side and add a new DWORD (32-bit).
  5. Give the new setting the name LocalAccountTokenFilterPolicy.
  6. Double click on that setting and give it a value of 1.

It’s probably wise to reboot after doing this, although it might not be needed. I’m not sure if it works straight away because I rebooted without trying.

Anyways, if you’re lucky you will be able to access administrative shares after performing these steps. If you’re unlucky, like me, doing all these things appears to have zero effect at all. Once again don’t panick, because there’s another hint/tip/solution coming your way.

Somewhere at some point during the installation or configuration of Windows 7, you will be asked to do something with a thing called Homegroup. It’s some weird new sharing tool that looks OK but isn’t quite what you’re used to. Once you have enabled that feature, you won’t be able to use the administrative shares. So the tip is: disable the homegroup feature.

  1. Open the control panel.
  2. Go to Network and Internet.
  3. Go to HomeGroup.
  4. Click on the blue link Leave the homegroup.

The popup dialog should point out itself, but I believe I picked to first option. Once I had left the homegroup, the administrative shares started working again.

I hope this post can help anyone who experiences the same problem.

Windows Vista: Explorer opens folders in a new window

Recently, Vista started opening folders in a new window even though “Open each folder in the same window” was selected in the folder options. Obviously something had changed but I didn’t know what. There were more indications that something was wrong, including:

  • Explorer opens folders in a new window, ignoring the folder options setting.
  • The Windows flag on C: is gone.
  • DVD-drives are labelled as CD-drive.
  • Trying to access a CD/DVD results in a Format blank disc dialog box.

Searching the internet resulted in heaps of complaints about the new window issue so finding the right fix wasn’t easy. It turned out that Internet Explorer 8 was the culprit. So there you have solution #1: uninstall IE8. Actually, that’s not a solution so I wasn’t satisfied :)

Another solution that I encountered a couple of times suggested to launch IE8 as administrator. Several users reported that this method fixed the problem, but it certainly didn’t fix it for me.

Eventually, I found a comment on the IEBlog with a list of 19(!) steps to fix it. Fortunately, and as noted in the comment too, step #11 seems to be the critical one. I was able to solve all issues mentioned above by doing this:

  1. Open a command prompt as administrator (right click -> Run as Administrator)
  2. Type: regsvr32 actxprxy.dll
  3. Click OK in the popup window.
  4. Reboot

And Vista was back to its normal self. YMMV!

Tracing two more Vista issues

After successfully defeating Windows Vista in the media playback department, I’m tracing two more issues. I only noticed these issues last week when trying Futuremark‘s latest incarnation of the PCMark benchmark: PCMark Vantage.

The first issue doesn’t really have a performance impact. When starting PCMark Vantage, it told me Windows Mail was running. Ehh? Unfortunately it was not a detection error because Windows Mail was really running. That’s pretty strange because (a) I haven’t even configured any email client on my laptop and (b) I would certainly not use Outlook Express or its new version as my email client. But there’s even more weirdness involved. By tracing the winmail.exe process, I found out it was launched by the same process that caused the media playback issues: “svchost.exe -DcomLaunch”. What the hell?

I’m still trying to find out why Windows Mail gets launched by the Dcom server. The bad part is that there’s much less information available than with the media playback issue. If anyone has any clue, please let me know through the comments.

The second issue surfaced when copying the PCMark installer from my main machine to my laptop. Transferring files across the network is SLOW! And it can’t be the network… Initiating the transfer from my PC results in a sustained network throughput of 90%. Initiating it from my laptop makes the throughput peak very briefly, followed by a stall in network activity. The net result is a 20 second difference doing exactly the same transfer. For a ~650MB file on a 100 megabit network, that’s a huge difference.

A search on the internet quickly revealed I’m not the only one. I’ve tried several suggested fixes, but none of them improved the performance. I had my hopes set on a tweak of the new TCP/IP stack in Vista, namely:
netsh interface tcp set global autotuninglevel=disabled
but that didn’t help either. Again, magical solutions or hints are much appreciated.

Aside from those issues, I’ve been much happier with Vista once I disabled the indexing service (it really does trash the HDD) and system restore. Both “features” put a high burden on the HDD and the system feels much more responsive with those two things turned off.

Windows Vista: Long delay when switching songs in media player

There you are: Windows Media Player (WMP) running, all songs loaded in its library and you hit the ‘play’-button. It picks the wrong song and you click the ‘next’-button. Instead of starting the next song immediately, a pretty long pause follows the release of the button. As if there’s some artificial intelligence pondering if it should play the file. Rest assured, the song will start eventually. You can live with that for a couple of songs and then the mind starts asking questions. I don’t have to wait in Windows XP so why should I have to wait in its youngest sibling? And so the quest for a solution starts…

The pause is the most noticeable event, but it’s the result of something else: one of the svchost.exe processes loves the CPU and starts eating cycles. So it’s some Windows service causing all of this, but which one (for the unknowing: svchost.exe does a lot in Windows and there are multiple processes with that name)? Process Explorer to the rescue! And that nifty program told me the spike in CPU usage was caused by “svchost.exe -DcomLaunch”.

The fun isn’t over yet. That process is associated with two services: DCOM Server Process Launcher and Plug and Play. For the Vulcans among us, all logic stops there for a second. What do those two services have to do with WMP? The answer is provided by Vista’s new audio engine. The new engine supports several audio “enhancements”. But for the enhancements to work, the engine needs to determine if your hardware is up to the task. And when does it check that? Each time a sound output device is accessed. That’s pretty nice if you can do a hot swap of sound hardware, but I don’t see me doing that anytime soon. Anyways, it does provide us with the link to the correct service because checking hardware is done by the “Plug and Play” service.

One might think that deactivating each enhancement would solve the problem, but that’s wishful thinking. The configuration of the enhancements is located in the properties of the sound hardware. When opening the tab, I found out that no enhancements were active. Hmmm… so why does it check the hardware? Well, it does that in case you actually enable an enhancement. To completely stop the hardware checking, you have to tick the box labelled Disable all enhancements. As soon as you do that, Vista finally understands you don’t want to use them :-)

It took me quite some time to figure this out. I hope this post can save some time for those who experience the same problem.

Zune Not Compatible With Vista

This is a rather funny fact unless you’re the owner of a Zune, Microsoft‘s new digital media player. Somewhere between all support pages for the Zune and its software is a document that lists the compatible operating systems.

The page mentions that the Zune software suite, released after Windows Vista went RTM, is not compatible with Microsoft’s upcoming operating system. The unlucky are told to “check back soon for updates”.

Nice one, Microsoft! 😉

Windows Vista Pricing

I just ran across a post listing the pricing info for Microsoft‘s upcoming OS Windows Vista. Considering what Vista is, that is a lot of money in my opinion.

Windows XP was just a visual refresh of Windows 2000. With all exciting features gone, Vista is again just a visual refresh. The only difference is that you do get an extra for the money compared to Windows XP: a bunch of useless features (the irritating security popups just to name one).